1

I migrated my images over to AWS S3 using the Amazon S3 plugin; however, now I'm seeing that the thumbnails in the CP are broken, and a brokenimage is displayed.

enter image description here

The full size images display fine in the CP and the front end. If I re-upload them, the thumbnails display correctly in the CP, but that's not an ideal solution.

Is there a way to make the images display correctly in the CP without re-uploading them?

  • Have you tried using the update asset indexes utility in the Control Panel? – Brad Bell Sep 24 at 22:40
  • I did not try that. Already re-uploaded everything. Agh! – BBaysinger Sep 24 at 22:41
  • I'm new to Craft. Think I read about that at some point. Would that likely have solved it? Feel free to post it as the answer. – BBaysinger Sep 24 at 23:01
  • Not sure if it would have solved it, but it's an easy first thing to try! Added an answer. – Brad Bell Sep 25 at 20:05
1

My first guess would have been that the asset indexes stored in the database are out of sync since it was recently migrated to a new Volume.

A way to fix that would be to run the "Update Asset Indexes" utility from the Control Panel.

1

It actually turns out to be an oversight on my part. It was confusing (after I manually replaced the missing assets), but in control panel > admin > settings > assets > volumes, I did not have the correct bucket selected for a couple of my volumes. I simply overlooked that option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.