0

I'm trying to import entries to a chanell using Feed me but having some issues with table and with some multilingual texte in a matrix field.

  • Craft edition & version Craft Pro 3.3.2
  • Feed Me 4.1.2

1. Table field

The Table field has 3 columns

  • From date : date field
  • Starting time : time field
  • Ending time : time field

I've try to format the date and time with different format (2012-04-23T22:00:00.999Z, 2019-08-11 22:00:00, 2019-08-11, 2019/08/11 ...) but the Feed me log always show empty value for those fields.

Feed me logs

{
    "title":"Family Breakfast",
    "webpageMatrix":{"new1":{"type":"blockBody","enabled":true,"collapsed":"1","fields":{"body":"<p>To bring ... <\/p>"}}},
    "subtitle":"Tour and workshops",
    "datesTable":[{"col1":null,"col2":null,"col3":null}],
    "lacentraleId":"189"
}

Json Feed

{
    "entries": [
        {
            "id": "189",
            "title": "Family Breakfast",
            "subtitle": "Tour and workshops",
            "body": "<p>To bring ... </p>",
            "images": [
                {
                    "url": "http:// ... .jpg",
                    "caption": "..."
                },
                {
                    "url": "http:// ... .jpg",
                    "caption": "..."
                }
            ],
            "categories": [
                {
                    "title": "Finishing"
                }
            ],
            "datesTable": [
                {
                    "col1": "2019-09-01",
                    "col2": "09:30",
                    "col3": "10:30"
                },
                {
                    "col1": "2019-09-02",
                    "col2": "09:30",
                    "col3": "10:30"
                }
            ]
        }
    ]
}

2. Matrix Field

I'm trying to import the body as a first block of webpageMatrix (a matrix field) and all is going well for the first language. But when I'm updating the second language with a second feed my body is overwrite with the new language value for all the three sites while I dont have this problem with my title and subtile.

  • The Matrix field webpageMatrix is set to be saved in all sites
  • The body field (redactor) in the blockBody is set to have a different value by site.
  • I have the same issue with the matrix field, I've logged it as a bug on github.com/craftcms/feed-me/issues/634 – Tim Bertens Nov 28 '19 at 21:19
  • For the other issue with dates, try some different settings using the options at 'Data provided for this field is formatted as' – Tim Bertens Nov 28 '19 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.