Running 3.2.4, and clicking on "new field" which calls /[admin]/settings/fields/new times out on our AWS servers where the DB is hosted in the cloud. It isn't an issue when everything's running localhost, but that's the only things we can see as a difference between them.

On the AWS hosted site, the CP and front end become unresponsive for that user in that browser for 15-20 minutes, but a newly created session from another browser works.

Could anyone else who similarly has their DB hosted on another machine try clicking Settings->Fields->New and see if it returns fast?

  • Tons of Craft 3 installs running on AWS (including id.craftcms.com/api.craftcms.com/etc.) so guessing it depends on your specific environment. Tried checking AWS and Craft/PHP log files to see where the hangup occurs?
    – Brad Bell
    Commented Jul 24, 2019 at 4:36

1 Answer 1


We discovered that the verbb/icon-picker plugin makes a call out to retrieve a file from it's cpresources cache and this was done with a fully qualified URL. Our AWS machines in CI/CD can be auto-provisioned and as such won't have their own name in the /etc/hosts file. So a call to https://fully.qualified.url/cpresources/577762fa/json/font-awesome.json?v=1556336828 was failing and hanging the site because it tried to get it five times in a row.

I've registered an issue with the Verbb folks, and put a PR together, so crossing my fingers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.