0

i'm running a macOS 10.15 Beta (to check out SwiftUI) but now i'm running into problems with craft, specifically with the php zip extension.

It's PHP 7.3.5 and i can't update it, because the install process doesn't recognize my system as an macOS above 10.6 :/

Has anyone an idea how to get the craft installation running under macOS 10.15 or how to fix the specific problem with the missing php zip extension?

Thanks in advance.

  • In the new MacOS version, the 32-bit support was dropped. This could be a possible explanation. Can you report us the error message? – Fred Jul 14 '19 at 10:07
  • That's i get after "composer create-project craftcms/craft ." Problem 1 - craftcms/cms 3.2.1 requires ext-zip * -> the requested PHP extension zip is missing from your system. - craftcms/cms 3.2.0 requires ext-zip * -> the requested PHP extension zip is missing from your system. - craftcms/cms 3.1.9.1 requires ext-zip * -> the requested PHP extension zip is missing from your system. … and so on ;) – mrnb Jul 14 '19 at 10:17
  • Have you tried to uninstall and install php@7.3? I'm also on macOS 10.15 (19A471t) and php7.3 and Craft works as expected. – Fred Jul 14 '19 at 10:38
  • i tried to install php with homebrew but that doesn't work either because of an old Xcode Version (couldn't update with beta, use xcode-beta) so i find now way to update. Can i update the system php in usr/bin/php? how? – mrnb Jul 14 '19 at 10:40
  • Then you should make sure that brew is working. What brew error are you getting? – Fred Jul 14 '19 at 10:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.