1

I have two radio buttons on a field. I check one of the options as default so it's checked automatically, but when I visit the entry it's on, both of them are unchecked.

I've tried deleting and remaking and it still doesn't select default.

Has anyone had this issue?

  • What version of Craft are you running? – Brad Bell Jul 14 '19 at 4:20
  • Hi, @BradBell. I'm using Craft Pro 3.1.26 – good_afternoon Jul 15 '19 at 20:49
  • Just updated to 3.22 and issue still present. – good_afternoon Jul 15 '19 at 21:04
  • I'm not able to reproduce this locally on a fresh Craft 3.2.2 install. If you want to send a database backup, your composer.json and composer.lock files over to support@craftcms.com and give us some steps to reproduce, we can look into it further. – Brad Bell Jul 15 '19 at 21:55
  • I'm having this issue now. In the past it always seems to select the default if it's a new entry(like I've read is the expected behaviour) but this time it's never selecting it. I've tried moving the fields to different sections, deleting all the entries and I recently used the project.yaml on a fresh install but that didn't help either. Craft version is "Craft Solo 3.2.10". – Moucky Aug 26 '19 at 20:18
1

I've got a radio button field on Commerce products that is also not visibly showing as checked. Inspecting shows the correct input is actually showing checked="". Manually adjusting this to checked="checked" makes the radio button re-appear. Doesn't help us in the meantime, but perhaps it's as simple as that to fix the issue? Safari and Firefox on Mac.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.