1

Please can anyone give me some pointers.

Just logged into the backend on an older (but live) 3.0.26.1 project. CP is now flashing multiple 'an unknown error occurred' messages on every CP request. Frontend pages are working fine, and my local dev cp version is fine too, no errors there.

I've updated my local dev version to 3.1.28 now, verified no errors and replaced the entire project on the live server but still getting the unknown error messages there.

Web inspector console on live CP is showing various javascript of status 400 codes 'failed to load resource' on things like :

mydomain.com/index.php?p=admin/actions/app/check-for-updates

mydomain.com/index.php?p=admin/actions/dashboard/get-feed-items

mydomain.com/index.php?p=admin/actions/app/get-utilities-badge-count

Also on things like Utilities > Updates the checking spins forever and never gets anywhere. I can't access any of my entries to edit. I've tried disabling all plugins and nuked cpresources folder. Still no luck. Clearing caches through the CP also results in a 400 error in the web inspector.

There's nothing in the db queue table and nothing new turning up in storage/logs or server error log.

Thinking it must be a server config issue but I have no idea on the further debugging process. Could it be folder permission issue?

Craft 3.1.28

PHP 7.2

Update If I set enableCsrfProtection => false in config/general the errors don't happen and everything is back to normal. Presumably not safe to leave it like this, but what to do to activate again and keep the errors away?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.