I have a plain text field in Craft and the content has an apostrophe. On the front end, the apostrophe gets turned into '

Not ideal! Thanks in advance..

  • 1
    You maybe ran into the same issue as this user?! Hope this helps.
    – carlcs
    Oct 9, 2014 at 16:52
  • I had tried what the answers in that link suggested, but I was just doing it on the wrong element. Oops! That solved it. Oct 9, 2014 at 17:46

2 Answers 2


The only way I can see this happening is if the field was originally a Rich Text Field, the content was entered, then the field type was swapped to a plain text field.

If that's the case, the Rich Text Field would have encoded the entities and saved them into the database.


Found the answer. I just had to do entry.title|raw

I had tried this before, but silly me had done it to the wrong heading, so I never saw it change! :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.