I am getting the error: An unknown error occurred for each file in a folder when I try Update Asset Indexes. The folder is a local folder that is outside of webroot. The files just contain json data. I have looked through Craft log files and apache log files and cannot find anything. Any ideas?

I have tried the following from other questions with the same error message and none of these made an difference.

Deleted entire craft/storage/runtime/ folder

An unknown error occurred - no log entry

Made sure no record in table assetindex has null for dateModified column

"An unknown error occurred" in assets screen

Reset folder ownership

permissions userphotos "an unknown error occurred"

  • Can you use the browser's developer console to check what's in the response body for Ajax requests running during the indexing? May 6, 2019 at 9:01
  • I have not built any code to load the content of the files yet since I can't add them through the reindex
    – Trevor Orr
    May 6, 2019 at 13:36
  • Symlink the folder they are in from your public web root?
    – Brad Bell
    May 6, 2019 at 16:47
  • I mean when you run the indexing process, your Craft install fires a bunch of Ajax requests to the server to try to index the files. Can you check the response body of those requests? If all seems normal, maybe enable devMode and try again. May 6, 2019 at 17:09
  • it appears to be some kind of ownership / permission issue even though I reset ownership / permission on the entire folder structure. I set it up on my work computer and it works perfectly. Maybe I just need to clone the repo again in a new folder and see if that works.
    – Trevor Orr
    May 7, 2019 at 2:51

1 Answer 1


Try to call the json file in the browser. There are chance of showing unknown error when the path of the json file is missing in Asset Index.

  • The files are outside of the webroot so I can't access them from the browser
    – Trevor Orr
    May 5, 2019 at 1:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.