1

I'm hitting an issue where signed-in non-admin users can't create a new entry with a front-end entry form (but can edit existing ones). Everything works except for this single instance:

✓ Admin creates and edits entries from non-ajax front-end form (Works!)

✓ Admin creates and edits entries from ajax front-end form (Works!)

✓ Non-admin edits their entries from a front-end form (Works!)

✗ Non-admin creates new entry from a front-end form (Doesn't work)

Craft is returning: "User is not permitted to perform this action"

Tried all of these with and without CSRF on. This is the user group permissions on the section it's submitting to:

enter image description here

Using: Craft 3.1.21.1 (with multi-site)

Edit: Original post stated that it was only a problem with ajax forms, but turns out it's all forms

  • 1
    Could you include the response of your ajax request? – Robin Schambach Apr 12 at 20:32
  • I have the same problem... Did you make any progress? – outline4 Oct 28 at 18:05
  • I solved my problem: I had to allow "edit site x" for the user group. – outline4 Oct 28 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.