1

This morning there were new updates for Craft CMS, Contact Form and Simplemap on a Craft Pro site I host. I updated everything through the Craft CP. After the update, the CP still shows available plugin updates. When I check composer.json everything is already updated.

I tried running ./craft update all through SSH, deleted caches, checked the OPcache settings with my hosting provider and checked the logs. Can’t find any reason why the CP shows plugin updates while everything is already updated.

I also contacted Craft support, and they suggested putting the question here. I hope anyone does have an idea what’s going on.

The server environment:

  • PHP 7.0.33
  • MySQL 5.5.5
  • Craft Pro 3.1.21.1
  • Yii 2.0.17

My composer file:

{
  "name": "craftcms/craft",
  "description": "Craft CMS",
  "keywords": [
    "craft",
    "cms",
    "craftcms",
    "project"
  ],
  "license": "MIT",
  "homepage": "https://craftcms.com/",
  "type": "project",
  "support": {
    "email": "support@craftcms.com",
    "issues": "https://github.com/craftcms/cms/issues",
    "forum": "https://craftcms.stackexchange.com/",
    "source": "https://github.com/craftcms/cms",
    "docs": "https://craftcms.com/docs",
    "rss": "https://craftcms.com/changelog.rss"
  },
  "require": {
    "craftcms/cms": "3.1.21.1",
    "vlucas/phpdotenv": "^2.4.0",
    "craftcms/redactor": "2.3.2",
    "rias/craft-position-fieldtype": "1.0.14",
    "craftcms/contact-form": "2.2.4",
    "ether/seo": "3.5.4",
    "ether/simplemap": "3.4.10",
    "nystudio107/craft-typogrify": "1.1.17",
    "matt-west/craft-recaptcha": "1.3.0"
  },
  "autoload": {
    "psr-4": {
      "modules\\": "modules/"
    }
  },
  "config": {
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
      "@composer dump-autoload -o",
      "@php craft setup/welcome"
    ]
  }
}
  • Can you try temporarily disabling opcache and see if the behavior changes? – Brad Bell Apr 5 at 23:26
  • Disabled OPcache. Problem still appears. This morning 3 updates available (contact-form (2.2.3 => 2.2.4), simplemap (3.3.5 => 3.4.11) and typogrify (1.1.16 => 1.1.17). I ran ./craft update all and only simplemap was updated in the CP. Contact form and typogrify still showing available updates. When I run ./craft update I see: contact-form 2.2.3 => 2.2.4 and typogrify 1.1.16 => 1.1.17. When I check my composer.json file it says Contact form is at version 2.2.4 and typogrify at 1.1.17. – Rinus Apr 8 at 9:34
  • So ./craft update shows available updates. When I check composer.json it says the updates are already installed. Who's right? :-) – Rinus Apr 8 at 9:39
  • And, when running ./craft update all or ./craft update plugin-name again, craft shows: Backing up the database ... done Performing update with Composer ... done Applying new migrations ... done Update complete! And updates are still available. – Rinus Apr 8 at 9:42
0

There was something wrong inside the vendor folder. Couldn't find what. What I did to solve it (thanks to Craft support):

  1. Rename vendor folder to vendor-old
  2. Ran composer clearcache to delete all content from Composer's cache directories

  3. Ran composer install to install all depencies in composer.json

  4. Deleted vendor-old folder

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.