1

I have a multi site setup for supporting multiple languages in Craft 3.

'/' => German '/en/' => English

In my general.php I have 'errorTemplatePrefix' => 'error/',

When I enter '/notexisting', my error/error.twig gets called. But when I enter '/en/notexisting', then the default Craft error message gets displayed "Page Not Found, Template not found: notexisting"

How do I get my error.twig called also for other sites?

  • 1
    That should usually work by default. Did you change something in your index.php or do you use different index.php files for each site? Have you changed the default behavior of Craft? Dev mode is tuned off I guess? Is your error folder in a site/sitegroup folder and not in the root of your templates folder? – Robin Schambach Apr 4 '19 at 14:01
  • Thank you very much, it was the last part – Volker Andres Apr 4 '19 at 14:53
  • @RobinSchambach Can you just post a checklist for multi site setup? Then I will accept that as the answer – Volker Andres Apr 4 '19 at 20:40
3
+50

There are several things that might be the issue in such cases, I'll list a few of them

  • Did you change your index.php so maybe Craft is unable to detect the current site?
  • Are there different index.php files in different folders in order to do the multisite setup instead of the single one? -> You should only have one for all
  • Do you have any plugins that might interfer and offer their custom error page / error behaviors?
  • Do you have any other events in your own custom plugin/module that includes a custom error handling?
  • Is your error template in the templates roots folder and not in a site/site group subfolder so Craft only selects it for a single site instead of globally?
  • Make sure dev mode is off
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.