0

When I upload a JPG image through Assets, the image quality is terrible. I dont mean a slight difference for web optimisation, but I mean REALLY bad! See screenshot.

Can't find any helpful about this issue which is strange. A few other posts mention the issue with image transforms, but this is not an image transform, its just the main image uploaded. Opening the image direct on the server shows this bad image so the original is clearly processed. I would not want our images processed if it affects quality (we optimise images ourselves).

I have not done much at all really, no plugins/modules added yet, just a basic template and a few text and asset fields. Its just to demonstrate Craft to a customer at the moment.

I have many CMSs on this server, like Wordpress and other Craft 2 installs, and we don't get this issue with other systems.

I have GD installed, I would prefer to keep that and not use ImageMagick, shouldn't have to use any image processing for just image upload should I?

Interestingly, if I open the original image on my computer and do a screenshot and create a new image from that, then upload that new image, it does not have such bad quality, it looks OK. So maybe its something inside the image. But the images are already used on another website (Wordpress) fine. I was hoping I can just import the images into Craft and not have to do any manual processing first.

Photoshop shows the image as RGB colour at 8 bits.

GD Spec from in Craft PHP Info:

GD Support  enabled
GD Version  bundled (2.1.0 compatible)
FreeType Support    enabled
FreeType Linkage    with freetype
FreeType Version    2.4.11
GIF Read Support    enabled
GIF Create Support  enabled
JPEG Support    enabled
libJPEG Version 6b
PNG Support enabled
libPNG Version  1.5.13
WBMP Support    enabled
XPM Support enabled
libXpm Version  30411
XBM Support enabled
WebP Support    enabled
gd.jpeg_ignore_warning  0

enter image description here

Thanks

Update July 24th 2019: Issue now gone, see comment below for further info.

  • It's not a solution as such but can you try to add this file via FTP and run Utilities → Asset Indexes → Update asset indexes. Does the file show properly then? – Oli Mar 20 '19 at 8:29
  • Sorry only just noticed this comment. I'm looking into it again as the customer raised it. But i have re-imported all images via FTP and they were fine, then I ran asset re-index and they were fine, then I uploaded images in Assets and the entry and they were fine. So it seems this issue has gone. Since having this issue we have upgraded to PHP 7.2 and many iterations of Craft to 3.2, so maybe something there fixed it. – Laurence Cope Jul 24 '19 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.