I've now tried installing Craft on multiple PCs to run a local dev environment, but keep getting the same problem. It installs fine, the System Report shows all green, but when I first load the Dashboard I get the message "An unknown error has occurred" and it fails to fetch Craft News items or updates, and then on the Plugin Store it states "The Plugin Store is not available, please try again later."

I've tried playing around with my Apache setup, but honestly I'm not particularly knowledgeable in that area.

All PCs have been running Windows 10, the latest version of WAMP server, PHP 7.2, and "latest" version of Craft (though it's now two installs behind, which is why I know the updates aren't working despite stating that I'm "up to date").

Live version of the site is working perfectly after upload via FTP, and I've tried reinstalling several times.

  • If you check your Craft storage/logs folder and search for [error], does anything related show up?
    – Brad Bell
    Commented Mar 18, 2019 at 5:19
  • @BradBell good suggestion, looks like it could be an SSL error: [error][GuzzleHttp\Exception\RequestException] GuzzleHttp\Exception\RequestException: cURL error 60: SSL certificate problem: unable to get local issuer certificate (see http://curl.haxx.se/libcurl/c/libcurl-errors.html) in C:\wamp64\www\craft\vendor\guzzlehttp\guzzle\src\Handler\CurlFactory.php:186 Which is odd because my certificate checks out Commented Mar 18, 2019 at 20:25

1 Answer 1


You need to download the CA certificate for curl and add it to your php.ini

  • I'm afraid that I've already tried that but it didn't change anything Commented Mar 17, 2019 at 22:12
  • Based on the error log found above, I deleted the cacert and tried again, following some of the advice here: GuzzleHttp Error I'm still not sure what I did differently to the first time I tried this, but it appears to have worked now, so marked as the solution. Commented Mar 18, 2019 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.