0

What is going on in Craft 3, seems like Composer has caused more problems than good. Every time I have had to update a dev/staging environment I run into issues and have to go and manually update the composer.json file to get updates to work.

This doesn't seem like how things should work.

Anyway on to the latest error trying to update to Craft 3.1.14

Composer output: Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- Can only install one of: yiisoft/yii2[2.0.16, 2.0.15.1].
- Can only install one of: yiisoft/yii2[2.0.16, 2.0.15.1].
- craftcms/cms 3.1.14 requires yiisoft/yii2 ~2.0.16.0 -> satisfiable by yiisoft/yii2[2.0.16].
- Installation request for craftcms/cms 3.1.14 -> satisfiable by craftcms/cms[3.1.14].
- Installation request for yiisoft/yii2 (installed at 2.0.15.1) -> satisfiable by yiisoft/yii2[2.0.15.1].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.
  • Can you post your composer.json file here? – Tony DeStefano Feb 26 at 18:29
  • 2
    Was finally able to get it working, had some permission issues in the vendor folder that was preventing the update from being able to remove files, fixed permissions via ssh, I then ran composer update via ssh and was able to finish the updates. – Bowenac Feb 26 at 18:32
  • That's good to hear! – Tony DeStefano Feb 26 at 18:33
  • 2
    @Bowenac if you could add that as an answer and accept it so other who come along know what the solution is, that would be great. – Jalen Davenport Feb 26 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.