1

Hey there and thanks in advance. We just moved our site to production as a beta site. The only thing that is different between this site and our local/staging site is the config file. The allowUpdates and allowAdminChanges is set to false. Databases are separate and all sites are running.

We I update entries on prod, they save but my site does not update. When I do the same change on local/dev the changes render on my dev site.

Am I missing something? Does allowUpdates and allowAdminChanges affect whether or not content will be updated on the site? Thought it might be a cache issue but why would it work on dev and not prod?

Any thoughts on this would be greatly appreciated.

Thank you,

1

Does allowUpdates and allowAdminChanges affect whether or not content will be updated on the site?

Nope.

Thought it might be a cache issue but why would it work on dev and not prod?

Caching is my first thought. Is production behind a CDN, Varnish or some other caching solution that dev is not?

Maybe the enableTemplateCaching config setting is set to false for non-production environments?

2
  • Looks like the enableTemplateCaching is set to true on staging and prod. I am going to set it to false and see if that changes anything. – Jason Feb 14 '19 at 11:58
  • Changed the settings and nothing changed. Going to look into it a little more today and tomorrow. Will update once I figure something out. Thank you for the response. – Jason Feb 14 '19 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.