1

I'm new to using Composer and I'm having trouble deploying to Laravel Forge. I am getting an error message that says:

Your requirements could not be resolved to an installable set of packages.

Problem 1 - Installation request for illuminate/support v5.5.44 -> satisfiable by illuminate/support[v5.5.44]. - don't install tightenco/collect v5.5.33|don't install illuminate/support v5.5.44 - Installation request for tightenco/collect v5.5.33 -> satisfiable by tightenco/collect[v5.5.33].

I didn't add these packages, they are dependencies of something I have added. So I have a few questions:

First, how do I resolve this? I am thinking that I should not go in and try to change the version numbers on anything because that would break things most likely, correct? Also, since they are not in my composer.json file, I'm not sure how I would do this.

Second, how do I determine what package I am installing uses this as a dependency?

Third, I have a couple of plugins that I have uninstalled in the CP that are still showing up in the composer.json file.Do I need to go back into my composer.json file and remove them? I thought this was done automatically when a plugin was uninstalled, but that may be my mistake. I am wondering if one or more of those plugins might be the culprit.

Thanks,

Brian

  • Can you 1) let us know what version of Craft you're running and 2) share your composer.json file? – Brad Bell Feb 11 '19 at 3:23
  • Thanks Brad. I'm running Craft 3.1.8. Here's a link to the composer json file: dropbox.com/s/kgwjmspl7sjedvq/composer.json?dl=0 – Brian Rivet Feb 11 '19 at 14:54
  • I don't know if it is relevant but I'm also getting errors when updating plugins in my local dev environment. I am getting errors when trying to update the Architect and ImageOptimize plugins. – Brian Rivet Feb 11 '19 at 23:21
  • For Architect I get a lot of errors like this: - symfony/yaml v4.1.0 requires php ^7.1.3 -> your PHP version (7.2.14-1+ubuntu18.04.1+deb.sury.org+1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement. Along with: - pennebaker/craft-architect 2.2.12 requires symfony/yaml ^4.1 -> satisfiable by symfony/yaml[v4.1.10, v4.2.2, v4.1.9, v4.2.1, v4.2.0, v4.1.8, v4.1.7, v4.1.6, v4.1.5, v4.1.4, v4.1.3, v4.1.2, v4.1.1, v4.1.0]. - Installation request for pennebaker/craft-architect 2.2.12 -> satisfiable by pennebaker/craft-architect[2.2.12]. – Brian Rivet Feb 11 '19 at 23:24
  • For Image Optimize I get: - Installation request for nystudio107/craft-imageoptimize 1.5.3 -> satisfiable by nystudio107/craft-imageoptimize[1.5.3]. - nystudio107/craft-imageoptimize 1.5.3 requires nystudio107/craft-imageoptimize-imgix ^1.0.2 -> no matching package found. I've already confirmed with Andrew that the tags are correct. – Brian Rivet Feb 11 '19 at 23:26
0

I was able to take your composer.json file, run composer update from it without any issues, do an install of Craft from that and update Craft/plugins and install/uninstall Craft/plugins from the Control Panel without any issues.

symfony/yaml v4.1.0 requires php ^7.1.3 -> your PHP version (7.2.14-1+ubuntu18.04.1+deb.sury.org+1) overridden by "config.platform.php" version (7.0) does not satisfy that requirement.

For that one, you've got this in your composer.json file:

  "config": {
    "sort-packages": true,
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },

Change it to this:

  "config": {
    "sort-packages": true,
    "optimize-autoloader": true,
    "platform": {
      "php": "7.2.14"
    }
  },

And it will go away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.