1

I've tried following the guide for setting up multiple sites (https://docs.craftcms.com/v3/sites.html#creating-a-site) but I think i'm missing something.

Firstly the craft install on your beta site, does it share the same database?

Secondly I'm not exactly sure what 'step 7' is asking me to do, could you please explain?

FYI, I'm using plesk on my hosting.

Thanks in advance

1

Firstly the Craft install on your beta site, does it share the same database?

Craft's multi-site setup is meant to use a single database.

Secondly I'm not exactly sure what 'step 7' is asking me to do, could you please explain?

Step 7: Configure Your Web Server and DNS

1.  Configure your web server so the domain (e.g. beta.craftcms.com) points at the web directory. Craft will automatically detect which site the browser is requesting.
2.  Update your DNS records so the domain points at the web server.

It will be difficult to answer without knowing your specific environment and where your domain name is registered or if you're just doing this locally with a development domain.

| improve this answer | |
  • The original Craft 3 install was on a subdomain - which is a dev site for us at the moment. It was using the Solo licence. Everything was fine. Then we bought and installed licence version of Craft 3. And we installed Craft 3 on a separate domain so we could test multi-site. The result is that the new domain Craft is live, but the original one is now giving errors - bit.ly/2DXFhIw – J.Intheflock Feb 7 '19 at 9:28
  • The environment is Plesk Onyx 17.8.11 running PHP 7.1.26 on both domains. – J.Intheflock Feb 7 '19 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.