0

http://denizen.tv/work/2011-kca-image-campaign

http://denizen.tv has been up and running well since June, but it's suddenly throwing 404s. It looks like the same /index.php/ problem I was recently having with my own Craft install. The coincidence makes me think it must be a bug with a recent release.

Anyone else getting this error?

  • The .htaccess file hasn't been modified? What happens if you set the 'omitScriptNameInUrls' config setting to true? – Brad Bell Oct 6 '14 at 0:30
  • 1
    Looks like the .htaccess file had been misnamed (on purpose). Adding back fixed the problem. But I hadn't changed anything since May/June, so could you guess why the problem happened only yesterday? thanks for the help – brian Oct 6 '14 at 12:24
  • 1
    Can you add that as an official answer, then? Maybe it was reading settings from cache the entire time and the cache was only recently cleared. – Brad Bell Oct 6 '14 at 15:36
3

Since files that begin with a dot are hidden by default in Unix-based systems like OS X, Craft ships with a “htaccess” file rather than “.htaccess”. If you are using Apache and want to use this file, you need to rename it to .htaccess when you upload it to your web server.

Not sure why suddenly your site stopped working, but I can tell you that Craft auto-updates will only ever touch files within the craft/app/ folder, so if your .htaccess file was misnamed, it’s definitely not due to a Craft auto-update.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.