4

I'm in a multi config env, local, staging & production. I sync my databases down to local then usually update locally, then push to staging and check again before going live.

The recent 3.1 updates aren't working for me. Usually, I go thru the control panel and all is fine.

Now I get the below. Minor issues for plugins I can usually sort out but how do I solve this one?

Composer output: Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- craftcms/vue-asset 1.0.2 requires craftcms/cms ~3.0.0-beta.1 -> satisfiable by craftcms/cms[3.0.37, 3.0.36, 3.0.35, 3.0.34, 3.0.33, 3.0.32, 3.0.31, 3.0.30.2, 3.0.30.1, 3.0.30, 3.0.29, 3.0.28, 3.0.27.1, 3.0.27, 3.0.26, 3.0.26.1, 3.0.25, 3.0.24, 3.0.19, 3.0.23.1, 3.0.23, 3.0.0-beta.1, 3.0.0-beta.2, 3.0.0-beta.3, 3.0.0-beta.4, 3.0.0-beta.5, 3.0.0-beta.6, 3.0.0-beta.7, 3.0.0-beta.8, 3.0.0-beta.9, 3.0.0-beta.10, 3.0.0-beta.11, 3.0.0-beta.12, 3.0.0-beta.13, 3.0.0-beta.14, 3.0.0-beta.15, 3.0.0-beta.16, 3.0.0-beta.17, 3.0.0-beta.18, 3.0.0-beta.19, 3.0.0-beta.20, 3.0.0-beta.21, 3.0.0-beta.22, 3.0.0-beta.23, 3.0.0-beta.24, 3.0.0-beta.25, 3.0.0-beta.26, 3.0.0-beta.27, 3.0.0-beta.28, 3.0.0-beta.29, 3.0.0-beta.30, 3.0.0-beta.31, 3.0.0-beta.32, 3.0.0-beta.33, 3.0.0-beta.34, 3.0.0-beta.35, 3.0.0-beta.36, 3.0.0-RC1, 3.0.0-RC2, 3.0.0-RC3, 3.0.0-RC4, 3.0.0-RC5, 3.0.0-RC6, 3.0.0-RC7, 3.0.0-RC7.1, 3.0.0-RC8, 3.0.0-RC9, 3.0.0-RC10, 3.0.0-RC10.1, 3.0.0-RC11, 3.0.0-RC12, 3.0.0-RC13, 3.0.0-RC14, 3.0.0-RC15, 3.0.0-RC16, 3.0.0-RC16.1, 3.0.0-RC17, 3.0.0-RC17.1, 3.0.0, 3.0.0.1, 3.0.0.2, 3.0.1, 3.0.2, 3.0.3, 3.0.3.1, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9, 3.0.10, 3.0.10.1, 3.0.10.2, 3.0.10.3, 3.0.11, 3.0.12, 3.0.13, 3.0.13.1, 3.0.13.2, 3.0.14, 3.0.15, 3.0.16, 3.0.16.1, 3.0.17, 3.0.17.1, 3.0.18, 3.0.20, 3.0.21, 3.0.22] but these conflict with your requirements or minimum-stability.
- craftcms/vue-asset 1.0.2 requires craftcms/cms ~3.0.0-beta.1 -> satisfiable by craftcms/cms[3.0.37, 3.0.36, 3.0.35, 3.0.34, 3.0.33, 3.0.32, 3.0.31, 3.0.30.2, 3.0.30.1, 3.0.30, 3.0.29, 3.0.28, 3.0.27.1, 3.0.27, 3.0.26, 3.0.26.1, 3.0.25, 3.0.24, 3.0.19, 3.0.23.1, 3.0.23, 3.0.0-beta.1, 3.0.0-beta.2, 3.0.0-beta.3, 3.0.0-beta.4, 3.0.0-beta.5, 3.0.0-beta.6, 3.0.0-beta.7, 3.0.0-beta.8, 3.0.0-beta.9, 3.0.0-beta.10, 3.0.0-beta.11, 3.0.0-beta.12, 3.0.0-beta.13, 3.0.0-beta.14, 3.0.0-beta.15, 3.0.0-beta.16, 3.0.0-beta.17, 3.0.0-beta.18, 3.0.0-beta.19, 3.0.0-beta.20, 3.0.0-beta.21, 3.0.0-beta.22, 3.0.0-beta.23, 3.0.0-beta.24, 3.0.0-beta.25, 3.0.0-beta.26, 3.0.0-beta.27, 3.0.0-beta.28, 3.0.0-beta.29, 3.0.0-beta.30, 3.0.0-beta.31, 3.0.0-beta.32, 3.0.0-beta.33, 3.0.0-beta.34, 3.0.0-beta.35, 3.0.0-beta.36, 3.0.0-RC1, 3.0.0-RC2, 3.0.0-RC3, 3.0.0-RC4, 3.0.0-RC5, 3.0.0-RC6, 3.0.0-RC7, 3.0.0-RC7.1, 3.0.0-RC8, 3.0.0-RC9, 3.0.0-RC10, 3.0.0-RC10.1, 3.0.0-RC11, 3.0.0-RC12, 3.0.0-RC13, 3.0.0-RC14, 3.0.0-RC15, 3.0.0-RC16, 3.0.0-RC16.1, 3.0.0-RC17, 3.0.0-RC17.1, 3.0.0, 3.0.0.1, 3.0.0.2, 3.0.1, 3.0.2, 3.0.3, 3.0.3.1, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9, 3.0.10, 3.0.10.1, 3.0.10.2, 3.0.10.3, 3.0.11, 3.0.12, 3.0.13, 3.0.13.1, 3.0.13.2, 3.0.14, 3.0.15, 3.0.16, 3.0.16.1, 3.0.17, 3.0.17.1, 3.0.18, 3.0.20, 3.0.21, 3.0.22] but these conflict with your requirements or minimum-stability.
- craftcms/vue-asset 1.0.2 requires craftcms/cms ~3.0.0-beta.1 -> satisfiable by craftcms/cms[3.0.37, 3.0.36, 3.0.35, 3.0.34, 3.0.33, 3.0.32, 3.0.31, 3.0.30.2, 3.0.30.1, 3.0.30, 3.0.29, 3.0.28, 3.0.27.1, 3.0.27, 3.0.26, 3.0.26.1, 3.0.25, 3.0.24, 3.0.19, 3.0.23.1, 3.0.23, 3.0.0-beta.1, 3.0.0-beta.2, 3.0.0-beta.3, 3.0.0-beta.4, 3.0.0-beta.5, 3.0.0-beta.6, 3.0.0-beta.7, 3.0.0-beta.8, 3.0.0-beta.9, 3.0.0-beta.10, 3.0.0-beta.11, 3.0.0-beta.12, 3.0.0-beta.13, 3.0.0-beta.14, 3.0.0-beta.15, 3.0.0-beta.16, 3.0.0-beta.17, 3.0.0-beta.18, 3.0.0-beta.19, 3.0.0-beta.20, 3.0.0-beta.21, 3.0.0-beta.22, 3.0.0-beta.23, 3.0.0-beta.24, 3.0.0-beta.25, 3.0.0-beta.26, 3.0.0-beta.27, 3.0.0-beta.28, 3.0.0-beta.29, 3.0.0-beta.30, 3.0.0-beta.31, 3.0.0-beta.32, 3.0.0-beta.33, 3.0.0-beta.34, 3.0.0-beta.35, 3.0.0-beta.36, 3.0.0-RC1, 3.0.0-RC2, 3.0.0-RC3, 3.0.0-RC4, 3.0.0-RC5, 3.0.0-RC6, 3.0.0-RC7, 3.0.0-RC7.1, 3.0.0-RC8, 3.0.0-RC9, 3.0.0-RC10, 3.0.0-RC10.1, 3.0.0-RC11, 3.0.0-RC12, 3.0.0-RC13, 3.0.0-RC14, 3.0.0-RC15, 3.0.0-RC16, 3.0.0-RC16.1, 3.0.0-RC17, 3.0.0-RC17.1, 3.0.0, 3.0.0.1, 3.0.0.2, 3.0.1, 3.0.2, 3.0.3, 3.0.3.1, 3.0.4, 3.0.5, 3.0.6, 3.0.7, 3.0.8, 3.0.9, 3.0.10, 3.0.10.1, 3.0.10.2, 3.0.10.3, 3.0.11, 3.0.12, 3.0.13, 3.0.13.1, 3.0.13.2, 3.0.14, 3.0.15, 3.0.16, 3.0.16.1, 3.0.17, 3.0.17.1, 3.0.18, 3.0.20, 3.0.21, 3.0.22] but these conflict with your requirements or minimum-stability.
- Installation request for craftcms/vue-asset 1.0.2 -> satisfiable by craftcms/vue-asset[1.0.2].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

Composer file:

{
  "name": "craftcms/craft",
  "description": "Craft CMS",
  "keywords": [
    "craft",
    "cms",
    "craftcms",
    "project"
  ],
  "license": "MIT",
  "homepage": "https://craftcms.com/",
  "type": "project",
  "support": {
    "email": "support@craftcms.com",
    "issues": "https://github.com/craftcms/cms/issues",
    "forum": "https://craftcms.stackexchange.com/",
    "source": "https://github.com/craftcms/cms",
    "docs": "https://craftcms.com/docs",
    "rss": "https://craftcms.com/changelog.rss"
  },
  "require": {
    "craftcms/cms": "3.0.33",
    "superbig/craft3-mobiledetect": "1.0.1",
    "pennebaker/craft-architect": "2.2.11",
    "mikestecker/craft-readability": "1.0.4",
    "craftcms/redactor": "2.1.6",
    "verbb/feed-me": "3.0.0",
    "verbb/redactor-tweaks": "2.0.1",
    "solspace/craft3-freeform-pro": "2.5.3",
    "nystudio107/craft-typogrify": "1.1.16",
    "rias/craft-position-fieldtype": "1.0.14",
    "svenjungnickel/redactor-font-awesome": "2.0.4",
    "dolphiq/iconpicker": "1.0.5",
    "verbb/super-table": "2.0.14",
    "superbig/craft3-templateselect": "2.0.0",
    "charliedev/section-field": "1.1.0",
    "dukt/facebook": "2.0.1",
    "joomkit/pdfthumbnailer": "1.0",
    "craftcms/guest-entries": "2.1.3",
    "nystudio107/craft-fastcgicachebust": "1.0.8",
    "studioespresso/craft-splashingimages": "1.1.0",
    "solspace/craft3-freeform": "2.5.3",
    "balazscsaba2006/cookiebot": "1.0.6",
    "nystudio107/craft-seomatic": "3.1.38",
    "aws/aws-sdk-php": "3.63.1",
    "bower-asset/bootstrap": "v3.3.7",
    "bower-asset/inputmask": "3.3.11",
    "bower-asset/jquery": "3.2.1",
    "bower-asset/punycode": "v1.3.2",
    "bower-asset/yii2-pjax": "2.0.7.1",
    "cakephp/core": "3.6.7",
    "cakephp/utility": "3.6.7",
    "craftcms/vue-asset": "1.0.2",
    "firebase/php-jwt": "v5.0.0",
    "google/auth": "v1.3.0",
    "google/cloud": "v0.71.0",
    "google/gax": "0.34.0",
    "google/protobuf": "v3.6.0.1",
    "grpc/grpc": "1.13.0",
    "hashids/hashids": "2.0.4",
    "hughbertd/oauth2-unsplash": "1.0.3",
    "imageoptim/imageoptim": "^1.3",
    "jakeasmith/http_build_url": "1.0.1",
    "kraken-io/kraken-php": "1.6",
    "ksubileau/color-thief-php": "v1.3.1",
    "league/csv": "8.2.3",
    "league/oauth2-facebook": "2.0.1",
    "masterminds/html5": "2.3.0",
    "michelf/php-smartypants": "1.8.1",
    "mobiledetect/mobiledetectlib": "2.8.32",
    "monolog/monolog": "1.23.0",
    "mtdowling/jmespath.php": "2.4.0",
    "mundschenk-at/php-typography": "v6.1.5",
    "nesbot/carbon": "1.32.0",
    "phenx/php-font-lib": "0.5.1",
    "php-science/textrank": "1.0.4",
    "pixel418/markdownify": "v2.1.11",
    "psr/cache": "1.0.1",
    "ralouphie/mimey": "1.0.8",
    "ramsey/uuid": "3.7.3",
    "rize/uri-template": "0.3.2",
    "sunra/php-simple-html-dom-parser": "v1.5.2",
    "symfony/inflector": "v3.3.6",
    "symfony/polyfill-php70": "v1.8.0",
    "symfony/property-access": "v3.3.6",
    "symfony/translation": "v3.3.6",
    "tinify/tinify": "1.5.2",
    "unsplash/unsplash": "2.4.3",
    "aelvan/imager": "v2.1.2",
    "craftcms/element-api": "^2.5",
    "nerds-and-company/schematic": "4.1.0"
  },
  "repositories": [
    {
      "type": "composer",
      "url": "https://asset-packagist.org"
    },
    {
      "type": "path",
      "url": "plugins/joomkit/pdfthumbnailer/"
    }
  ],
  "autoload": {
    "psr-4": {
      "modules\\": "modules/"
    }
  },
  "config": {
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
      "@composer dump-autoload -o",
      "@php craft setup/welcome"
    ]
  }
}
  • This likely an issue in your composer.json file. Can you edit the original question to share it? – Brad Bell Jan 21 at 15:43
2

Have the same issue with upgrading. In my case, the package itself doesn't appear in my composer.json. It does appear in my composer.lock file thought.

Edit: Removing the composer.lock and doing a fresh install fixed this issue for me. The package was a dependency for SEOmatic, but removing SEOmatic didn't remove it from my lock file.

1

Solved: removed "craftcms/vue-asset": "1.0.2" and changed craftcms version number. I also had to manually change a few required items as phpstorm seemed to be reverting their versions creating more problems

  • Yes i had a few quirks with SEOmatic as i accidentally upgraded production db then synced it to local and ran into troubles. Probably the worst experience after a few years using craft so once a blue moon is not all bad. I think the blitz vendor folder is a good way to go in future. – joomkit Jan 25 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.