4

One of my Craft websites is taking a long time (30+ seconds) to load. The /admin area also loads slowly. I have other installs of Craft on the same server that don't experience this problem.

Are there any debugging tools built into Craft to see which part of the site is taking the long time to load?

Some server information:

  • DigitalOcean instance in SF with 2GB ram
  • Nginx 1.6.0 (set up through Forge).
  • PHP 5.5.12-2

I have tried a couple things:

  • Disabling gzip (I recently enabled it)
  • Restarting the server
  • Changing the mysql connection address from localhost to 127.0.0.1 (also tried server IP)
  • Enabling memcached as the cache type
  • Clearing cache/rebuild assets/reindex search

The error logs don't show anything unusual.

7

There is a reasonable chance that this is due to a specific plugin.

Try disabling all of your plugins, and see if the site is loading quickly again. If it is, try re-enabling each plugin one by one, to determine which of them may be causing the slowdown.

It's important to remember that your plugins actually get loaded on every single page load, both front-end and back-end.

5
  • 1
    If you're using the Smart Map plugin, it's possible that is causing your problem. The plugin relies on FreeGeoIp.net to automatically geolocate. That service seems to be down right now. If this is the case, feel free to contact me at support@doublesecretagency.com ... I'm currently working on a fix for this issue, and may be able to guide you through a temporary workaround. – Lindsey D Oct 4 '14 at 23:11
  • Lindsey, this was it! Thanks. Looking forward to the fix. – Jason D Oct 4 '14 at 23:21
  • Is there any way to time-profile plugins and other parts of Craft? My server now responds in ~1.8s, which still seems high and makes me wonder where I can further optimize it. – Jason D Oct 4 '14 at 23:23
  • That's a great question... You may want to open that as a brand new question. – Lindsey D Oct 4 '14 at 23:24
  • UPDATE: I've updated the plugin to remove any heavy logic from the init method, per Brad's comment on this other thread... The updated version released last night includes a patch which almost completely resolves this issue. (A future release will iron out the remaining related details.) – Lindsey D Oct 5 '14 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.