0

I've got a local installation of Craft 3.0.37 and Craft Commerce 2.0.0-beta.15 running on MAMP. When completing an order, an empty response is given by the browser. The same thing happens when trying to look at that error from the admin area.

When I look into the MYSQL logs, I see the following error for both situations:

2019-01-13T13:32:43.718637Z 300 [Note] Aborted connection 300 to db: 'DBNAME' user: 'root' host: 'localhost' (Got an error reading communication packets)

I've tried upping the limits of the MYSQL setup, but to no avail.

  • Strange, can you try deleting all orders from the order index screen and making a new order? issue persists? – Luke Holder Jan 14 '19 at 12:48
  • I also use MAMP and i have the same problem. I also deleting all orders from the order index and make a new order. I always have the same problem. Any solutions? – Maximilian Schwarz Jan 16 '19 at 8:06
  • @LukeHolder Yeah I've tried that too, but to no avail.. – Thomas Jan 16 '19 at 11:45
0

Try updating your MySQL config max_allowed_packet config setting to a higher value and verify the change has been applied to your running instance.

https://dba.stackexchange.com/questions/19135/mysql-error-reading-communication-packets

  • I've tried increasing it to 256M but it still doesn't work unfortunately. – Thomas Jan 21 '19 at 7:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.