2

After installing craft on apache server, when I try to access control panel using web/admin, serwer throws 404 error. I didnt changed cpTrigger setting. Default craft template that displays after installation is displayed correctly.

.htaccess file in web directory was not modified in any way, its contents are default:

<IfModule mod_rewrite.c>
    RewriteEngine On

    # Send would-be 404 requests to Craft
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^/(favicon\.ico|apple-touch-icon.*\.png)$ [NC]
    RewriteRule (.+) index.php?p=$1 [QSA,L]
</IfModule>
  • Are you running nginx? What is your nginx config? – Jørgen Dec 21 '18 at 10:33
  • Apache, just updated my post. – Ded Nolyxeux Dec 21 '18 at 10:35
  • Does web/.htaccess exist on the server? – Jørgen Dec 21 '18 at 10:38
  • Yes, it does, it was not modified in any way. Updated my post. – Ded Nolyxeux Dec 21 '18 at 10:45
  • What happens if you navigate to yoururl.com/index.php?p=admin? – Jørgen Dec 21 '18 at 10:46
1

Web is the public web folder if you followed the recommended install location, so the link to login is just /admin, i.e.

http://your-domain/admin

  • Sorry, i didnt included all info in my post - default craft template that displays after installation is displayed correctly, so url is correct. – Ded Nolyxeux Dec 21 '18 at 16:23
  • Thanks this worked for me, first time install. Looks pretty neat! – Nathaniel Flick Apr 9 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.