1

When I try to install or update a plugin from the Control Panel, I see a message "Updating Composer Dependencies" and then the following error occurs. I'm running Craft on a local environment. Installing and updating from the command line works fine.

Status: Internal Server Error

Response:
PHP Fatal Error 'yii\base\ErrorException' with message 'Maximum execution time of 30 seconds exceeded'
in ...\vendor\composer\composer\src\Composer\Util\RemoteFilesystem.php:555

Stack trace:
#0 [internal function]: yii\base\ErrorHandler->handleFatalError()
#1 {main}
2

You need to figure out where your PHP config file is located (php.ini) and increase the value for the max_execution_time setting.


The best way to locate your php.ini:

  • If you can run php from the command line, run php --ini. Alternatively you could use php -i | grep 'Configuration File' to search the full phpinfo(). More info...

  • If php isn't accessible via the CLI, you can also create a simple php file that contains the following snippet. Load it up in your browser and search the page for "Configuration File". This will give you the location of your php.ini.

<?php

phpinfo();

Other options:

  • If you're using a Laravel Valet / Homebrew setup, the php.ini file is located at /usr/local/etc/php/X.X/php.ini where X.X is your PHP version number.

  • If you're running MAMP Pro, I believe they provide a built in editor to customize this - see How do you change php.ini values in MAMP Pro?

3
  • I updated the timeout and ran the updater for Craft CMS and now the previous installation seems to be blown out. Warning: require(vendor/craftcms/cms/bootstrap/web.php): failed to open stream: No such file or directory in C:\Users\rickn\Documents\Craft\Projects\Untye\web\index.php on line 20 Fatal error: require(): Failed opening required 'vendor/craftcms/cms/bootstrap/web.php' (include_path='.;C:\php\pear') in
    – Rick
    Dec 12 '18 at 21:16
  • try removing your vendor folder entirely and run composer install from the command line... Dec 12 '18 at 21:27
  • Thanks. Then I get - The requested package craftcms/cms (locked at 3.0.34, required as 3.0.35) is satisfiable by craftcms/cms[3.0.34] but these conflict with your requirements or minimum-stability.
    – Rick
    Dec 12 '18 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.