When I try to login to my admin area, I get this error: HTTP 400 - Bad Request - yii/web/BadRequestHttpException Unable to verify your data submission.

The login button stays faded out, but it usually turns red once I type in the username/password. Front-end of the site is working just fine.

I've tried clearing my cache/cookies and using a completely different browser/computer, but it's still giving me that error.

Stack trace:

2018-12-04 11:43:49 [-][-][hms8j39h5es918dp04hkjcmjs1][error][yii\web\HttpException:400] yii\web\BadRequestHttpException: Unable to verify your data submission. in /vendor/yiisoft/yii2/web/Controller.php:166
Stack trace:
#0 /vendor/craftcms/cms/src/web/Controller.php(83): yii\web\Controller->beforeAction(Object(yii\base\InlineAction))
#1 /vendor/yiisoft/yii2/base/Controller.php(155): craft\web\Controller->beforeAction(Object(yii\base\InlineAction))
#2 /vendor/craftcms/cms/src/web/Controller.php(104): yii\base\Controller->runAction('login', Array)
#3 /vendor/yiisoft/yii2/base/Module.php(528): craft\web\Controller->runAction('login', Array)
#4 /vendor/craftcms/cms/src/web/Application.php(282): yii\base\Module->runAction('users/login', Array)
#5 /vendor/craftcms/cms/src/web/Application.php(542): craft\web\Application->runAction('users/login', Array)
#6 /vendor/craftcms/cms/src/web/Application.php(266): craft\web\Application->_processActionRequest(Object(craft\web\Request))
#7 /vendor/yiisoft/yii2/base/Application.php(386): craft\web\Application->handleRequest(Object(craft\web\Request))
#8 /index.php(21): yii\base\Application->run()
#9 {main}
up vote 0 down vote accepted

I fixed it! Just renamed cpresources folder to cpresources2 (could also have deleted it, I suppose), cleared my cache, and now I can log in.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.