1

I have a site that's been running Craft 3 and has been running smoothly for several months now.

I was going to update a post today, and noticed that there were updates to Craft 3 that needed to happen (there were several craft updates, along with two plugins). I selected the Craft CMS first to update, and after hitting the update button, it did its thing for about a minute, then gave me a message that the update failed. When I tried to go back to my admin panel, I got the HTTP ERROR 500. Same when going straight to the website.

I tried change my php mode from FastCGI to just CGI as suggested in another post, but that hasn't helped. I also tried setting the devMode to true in my general.php config file, but nothing has changed there.

At this point, I'm dead in the water.

Any suggestions?

1

If the error 500 is displayed by craft, look in craft/storage/logs (i.e. phperrors.log)

Otherwise have a look at the server logfiles, if you have access to them. The Apache (or whatever http server you use) error log might be useful.

1

Brad Bell responded directly to my support question. Here's what he suggested that worked for me. Editing the php.ini file wasn't the solution (but that could be because I'm on a VPN on Dreamhost, and have had similar issues with a wordpress build. Wanted to included it in case someone finds it useful). Deleting the Vendor folder did the trick for me.

Most likely what initially happened was you hit a fatal PHP error like PHP timing out, or runs out of memory.

Try editing your php.ini file and increasing the memory_limit setting to at least 256M, and the max_execution_time setting to at least 120.

If you’re not sure where your php.ini file is located, create a PHP file called ini.php alongside your index.php file with this:

php echo 'Loaded php.ini: ' . php_ini_loaded_file(); Then access that file in your web browser by going to http://your-> project.test/ini.php.

Once you’ve made your changes, restart your web server and that should prevent it from happening again going forward.

To fix your immediate situation and get your site back into a usable state, the easiest thing to do is if you have Composer installed from the command line (https://getcomposer.org/doc/00-intro.md#installation-linux-unix-osx), the nuke your site's vendor folder and composer.lock file, then run composer update from your project's root to get a fresh set of Craft and its dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.