1

I'm using MAMP Pro for local development and was gong to set up my site with SSL this time around. I got a self-signed cert for local dev and I can go to my development site over https:// without any trouble but when I try to go to the control panel I get 404 error. I've updated the .htaccess file as suggested on Enforcing SSL for CP Requests but I still get a 404 error. All the Stack articles I could find on this issue were of no help either. Any suggestions? Something obvious that I'm overlooking?

  • Did you ever get this solved? I'm running into the same issue. – Andrea Hall Mar 7 '19 at 18:14
2

tl;dr: In my case, adding AllowOverride All back in to httpd.conf fixed the issue.

I was having the same issue on my staging server. I noticed that, in addition to /admin throwing a 404, all of my site's subpages were 404-ing. This cause me to try the unrouted index.php url for a subpage (mysite.com/index.php?p=subpage) and it worked! Note, this wasn't working for /index.php?p=admin because it was properly routing to /admin/login. Plugging in /index.php?p=admin/login worked.

I ran through the Craft guide for removing index.php from urls. Everything was set up properly, but my server admin found that AllowOverride All had been commented out of httpd.conf during a server update and was never un-commented. Adding AllowOverride All back in to httpd.conf fixed the issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.