1

I am working on a project with multiple developers and another member of the team is getting on with a Plugin to assist with some CraftCommerce integrations.

As it's not a publicly available plugin, it's being stored locally in our repo.

However, whenever I run any Composer command on my local machine I get the following error:

[RuntimeException]
  Package <agency>/<plugin> cannot install to
  "/Users/jaycollett/Development/project/build/custom/<plugin>"
  inside its source at "/Users/jaycollett/Development/project/build/
  custom/<plugin>"

We have found this response from Andrew Welch, but it can't be this because our Composer.json repositories section is as follows:

  "repositories": [
    {
      "type": "composer",
      "url": "https://asset-packagist.org"
    },
    {
      "type": "path",
      "url": "./custom/<plugin>"
    }
  ]
1

After discussing it with the team we worked out that deleting the plugin directory from the /vendors folder and rerunning composer install resolved it. Not sure why though...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.