3

I have some issues with the asset handling of files containing Umlauts. Specifically it seems that the uploaded files on the server get renamed to a "broken" filename.

Zweigänger-1960.jpg becomes ZweigaÌnger-1960.jpg

No issues in the DB fields.

What could be the reason for that? What I'm overlooking? Also a solution similar to "limitAutoSlugsToAscii" would work for me or even renaming the files according to a pattern.

  • I'm not able to reproduce this locally. Are you seeing the mangled name on the file system or in the database? If the file system, which OS are you running? – Brad Bell Sep 30 '14 at 21:23
  • Thanks and I'm sorry, after a day rest and coming back to the project the images are displayed properly. Likely I had some cache problems or something (also updated to the latest craft version). I still have the messed up filenames on my FTP client, but that's a isolated problem there. – Pascal Mollet Oct 1 '14 at 14:01
  • Fair enough... can you add that as an official answer? – Brad Bell Oct 1 '14 at 14:55
3

I ran into the same problem lately, but got no clues from the accepted answer.

As of Craft 2.4 though, is a config setting that limits asset filenames to ASCII, so I'm happy with this workaround:

'convertFilenamesToAscii' => true

When storing assets in folders derived from the entry slug, you will additionally need to add the following:

'limitAutoSlugsToAscii' => true

Minor hassle: These settings naturally won't rename existing files and entries, so you need to touch each one in the control panel to take effect.

(I'm not completely convinced this filename issue is Craft's fault, since the file paths are broken/garbled in Coda, Safari and Safari for iOS – but work just fine in Firefox and Chrome by way of in-browser url-encoding.)

| improve this answer | |
0

Looks like I had a combination of two separate issues on my side. Images showed up correctly when I tried it again (also made a craft updated in the meantime), likely some caching or browser issue. On the other hand my FTP client had some encoding issues to display the filenames correctly.

Issue resolved for me.

| improve this answer | |
  • For me, the original poster's issue persists, and the accepted answer did not fix it. I found a workaround, though. – Avant la lettre Jun 4 '15 at 12:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.