Working in devMode, when trying to edit an existing single or structure entry, I get an InvalidArgument error

yii\base\InvalidArgumentException: Syntax error. in ...vendor/yiisoft/yii2/helpers/BaseJson.php:133

if (isset($availableErrors[$lastError])) {
    throw new InvalidArgumentException($availableErrors[$lastError], $lastError);

I notice in Chrome tools I get a bunch of Craft is not defined errors any ideas?

2 Answers 2


Was an issue with my Simple.json redactor config


    buttons: [bold, italic],
    toolbarFixed: true

Needed to be

    "buttons": ["bold", "italic"],
    "toolbarFixed": true

Just had the same error. Something went wrong during the update to craft 3.4.

In my case, it had todo with the corrupted stored settings information in the database.

The solution was to remove the serialized content in the info table. You might want to safe it first though ;) After I deleted the serialized settings and reloaded the admin page, craft rebuild it and everything works fine now.

Maybe this helps someone ;)

  • 1
    I had the same error message and also found this page (my Redactor configs are fine), something went from updating from 3.1 to 3.4 this morning Commented Jan 29, 2020 at 12:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.