1

I have a Craft 3 install on my client's Windows machine running Apache, PHP and MySQL.

We purchased an SSL certificate but the main Admin login page (on SSL) keeps loading cpresources assets over HTTP which cause all of these CSS and JS assets to be blocked by the browser. However, loading these assets over https in a browser works fine.

The Site URL is indeed set to https. I've tried to force change the URL in config/general.php using the siteUrl and baseCpUrl parameters. I've also tried clearing Craft's cache and removed the www/storage/* and web/cpresources/* content but nothing works.

I don't have a https redirect in .htaccess as I believe the force redirect was set up when the SSL was installed (I don't have how this step was done).

Does anyone know how to solve this? The admin page is totally broken and unusable at the moment.

While the server setup is different, this issue might be related to the below. However I wasn't able to solve my problem based on it. Craft Admin assets do not load over https (Apache & Cloudflare)

  • Biko. Did you find an answer? I'm suffering the same problem on a self hosted server from a client. – Harold Maduro Apr 16 '19 at 15:19
  • @HaroldMaduro sorry I forgot how this was resolved! – biko Sep 12 '19 at 11:14
  • @HaroldMaduro Hey hopefully not too late but the fix was to delete the content of the /cpresources folder and that did the trick. – biko Dec 5 '19 at 4:06
3

The fix was to delete the content of the /cpresources folder and that did the trick.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.