1

Suddenly, I can't add any entry to a structure. When I try to save a record, I've got "Could not find a unique URI for this element“. Although, the slug is perfectly valid and unique, but whatever I type in the slug field, same message "Could not find a unique URI for this element". I only got a couple of entries in this structure, so I could not have possibly hit the 'maxSlugIncrement' limit… Thanks for your help.

2
  • What is the Uri format for the section? Oct 13, 2018 at 21:38
  • The Uri format is "numeros/{numeroDeLaParution}" The "numeroDeLaParution" is a field from one of the Entry of this Structure. The strangest thing is everything works fine until a need to edit some data in the already created entries, but then I've got this "Could not find a unique URI for this element" and then I can't record anymore changes, netheir can I create new entries!
    – scandella
    Oct 14, 2018 at 18:45

1 Answer 1

1

The Uri of each element must be unique but if your Uri format is something that might not render a unique string you'll receive the error you are facing with.

As soon as you include some unique identifier like { id } or { slug } into your sections uri it will work again. Right now you can only save an entry if the field value is unique

1
  • Hi Robin, Using a unique identifier did the trick. Thanks for your help.
    – scandella
    Oct 15, 2018 at 7:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.