2

I've got another update issue with the following error. Can anyone help?

    craftcms/cms 3.0.27 requires yiisoft/yii2-queue 2.1.0 -> 
    satisfiable by yiisoft/yii2-queue[2.1.0] but these conflict with your requirements or minimum-stability.

composer.json looks like this

{
"name": "craftcms/craft",
"description": "Craft CMS",
"keywords": [
"craft",
"cms",
"craftcms",
"project"
],
"license": "MIT",
"homepage": "https://craftcms.com/",
"type": "project",
"support": {
"email": "support@craftcms.com",
"issues": "https://github.com/craftcms/cms/issues",
"forum": "https://craftcms.stackexchange.com/",
"source": "https://github.com/craftcms/cms",
"docs": "https://craftcms.com/docs",
"rss": "https://craftcms.com/changelog.rss"
},
"require": {
"craftcms/cms": "3.0.23.1",
"vlucas/phpdotenv": "v2.4.0",
"craftcms/ckeditor": "1.0.0-beta.2",
"craftcms/redactor": "2.1.6",
"cebe/markdown": "1.1.2",
"composer/ca-bundle": "1.1.1",
"composer/composer": "1.6.3",
"composer/semver": "1.4.2",
"composer/spdx-licenses": "1.3.0",
"craftcms/oauth2-craftid": "1.0.0.1",
"craftcms/plugin-installer": "1.5.2",
"craftcms/server-check": "1.1.1",
"creocoder/yii2-nested-sets": "0.9.0",
"danielstjules/stringy": "3.1.0",
"doctrine/lexer": "v1.0.1",
"egulias/email-validator": "2.1.4",
"elvanto/litemoji": "1.3.1",
"ezyang/htmlpurifier": "v4.10.0",
"guzzlehttp/guzzle": "6.3.3",
"guzzlehttp/promises": "v1.3.1",
"guzzlehttp/psr7": "1.4.2",
"justinrainbow/json-schema": "5.2.7",
"league/flysystem": "1.0.44",
"league/oauth2-client": "2.2.1",
"mikehaertl/php-shellcommand": "1.2.5",
"paragonie/random_compat": "v2.0.12",
"pixelandtonic/imagine": "v0.7.1.3",
"psr/http-message": "1.0.1",
"psr/log": "1.0.2",
"seld/cli-prompt": "1.0.3",
"seld/jsonlint": "1.7.1",
"seld/phar-utils": "1.0.1",
"swiftmailer/swiftmailer": "v6.0.2",
"symfony/console": "v3.3.6",
"symfony/debug": "v3.3.6",
"symfony/filesystem": "v3.3.6",
"symfony/finder": "v3.3.6",
"symfony/polyfill-mbstring": "v1.8.0",
"symfony/process": "v3.3.6",
"yiisoft/yii2": "2.0.15.1",
"yiisoft/yii2-bootstrap": "2.0.8",
"yiisoft/yii2-composer": "2.0.6",
"yiisoft/yii2-debug": "2.0.13",
"yiisoft/yii2-queue": "2.0.2",
"yiisoft/yii2-swiftmailer": "2.1.1",
"zendframework/zend-escaper": "2.6.0",
"zendframework/zend-feed": "2.8.0",
"zendframework/zend-stdlib": "3.2.0",
"solspace/craft3-freeform": "2.4.0",
"dolphiq/redirect": "1.0.18"
 },
"autoload": {
"psr-4": {
  "modules\\": "modules/"
}
},
"config": {
"optimize-autoloader": true,
"platform": {
  "php": "7.0"
}
},
"scripts": {
"post-root-package-install": [
  "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
],
"post-create-project-cmd": [
  "@composer dump-autoload -o",
  "@php craft setup/welcome"
]
}
}
  • Can you share your project's composer.json file? – Brad Bell Oct 16 '18 at 0:11
  • That doesn't looks like a Craft composer.json file... it should be the one at the root of your Craft project's folder. – Brad Bell Oct 20 '18 at 3:18
  • Apologies - updated the question – Andrew Oct 30 '18 at 12:37
1

How about changing the yii2-queue version number in composer.json and then running a composer update?

| improve this answer | |
0

Change your composer.json's "require" section to this:

"require": {
    "craftcms/cms": "^3.0.23.1",
    "vlucas/phpdotenv": "^v2.4.0",
    "craftcms/ckeditor": "^1.0.0-beta.2",
    "craftcms/redactor": "^2.1.6",
    "solspace/craft3-freeform": "^2.4.0",
   "dolphiq/redirect": "^1.0.18"
},

If you have Composer installed from the command line (https://getcomposer.org/doc/00-intro.md#installation-linux-unix-osx), then you can run composer update from your project's root, let it complete, load the Craft Control Panel and you should be set.

If you don't have Composer installed from the command line, then running an update from Craft's Control Panel should basically achieve the same thing.

| improve this answer | |
  • Doing this resulted in a server error 500 unfortunately. – Andrew Nov 5 '18 at 16:39
  • What's the underlying error message? If Craft generated it, it'll be in storage/runtime/logs. If your web server did, it'll be in your web server's error logs. – Brad Bell Nov 5 '18 at 20:12
  • The server error was: – Andrew Nov 6 '18 at 9:31
  • Warning: require(.../vendor/craftcms/cms/bootstrap/web.php): failed to open stream: No such file or directory in .../public_html/index.php on line 20 – Andrew Nov 6 '18 at 9:32
  • Fatal error: require(): Failed opening required '.../vendor/craftcms/cms/bootstrap/web.php' (include_path='.:/opt/cpanel/ea-php70/root/usr/share/pear') in .../public_html/index.php on line 20 – Andrew Nov 6 '18 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.