11

I have a matrix field with around 26 block types with between 2-6 fields on each. It seems like I've hit a limit and cannot add any more fields to any of the block types. I can add a field if i delete one.

I get the following error "Undefined index: type"

/var/www/dev/domain.co.uk/craft/app/fieldtypes/MatrixFieldType.php(118)

I'm running Craft Pro 2.1.2563

Matt

  • Have you tried upgrading? There have been a fair few Matrix fixes since then. You could upgrade locally first to see if it affects anything else. – Josh Angell Sep 26 '14 at 12:27
  • Yes, I tried upgrading this morning but still get the same problem locally. It seems like everything isn't getting posted when saving the matrix field. – Matthew Woods Sep 26 '14 at 13:09
  • In that case it might be best to submit a support request to P&T through your control panel? They are usually very swift to respond. – Josh Angell Sep 26 '14 at 14:44
  • I wonder if it's related to this issue... There are a few places around the system with an inherent limit of 100. You say you have 2-6 fields (average 4) per block type... ~25 * ~4 = ~100 – Lindsey D Sep 26 '14 at 16:50
15

There's about a 99% chance you're bumping into your php.ini file's max_input_vars value and/or its post_max_size. If you bump those to higher values, it should start working as expected.

Note that you may have to restart your web server for the settings to take affect.

| improve this answer | |
  • Cheers Brad, that's fixed the problem, works like a charm. – Matthew Woods Sep 30 '14 at 9:24
  • 3
    Brad for president. – Anna_MediaGirl Apr 8 '15 at 18:51
  • 2
    For nginx users, make sure you run service php5-fpm reload before you restart nginx, the changes did not take affect until I did that. Thanks Brad! – Brad Feb 11 '16 at 18:34
  • This solved it! Thanks a lot! I would have never thought of this! – Luke Dec 8 '16 at 18:52
  • I set post_max_size to 50 and max_input_vars to 500 . I thoughtthis is enough. We still have problems here... – Simon Franzen Jan 30 '18 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.