1

I try to update my craft3 cms system.

Ошибка: An error occurred

Вывод: Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

Problem 1
- The requested package oneup/contao-security-checker-bundle could not be found in any version, there may be a typo in the package name.
Problem 2
- Installation request for craftcms/cms 3.0.22 -> satisfiable by craftcms/cms[3.0.22].
- craftcms/cms 3.0.22 requires enshrined/svg-sanitize ~0.9.0 -> satisfiable by enshrined/svg-sanitize[0.9.0] but these conflict with your requirements or minimum-stability.
Problem 3
- craftcms/cms 3.0.22 requires enshrined/svg-sanitize ~0.9.0 -> satisfiable by enshrined/svg-sanitize[0.9.0] but these conflict with your requirements or minimum-stability.
- craftcms/redactor 2.1.6 requires craftcms/cms ^3.0.0-RC15 -> satisfiable by craftcms/cms[3.0.22].
- Installation request for craftcms/redactor 2.1.6 -> satisfiable by craftcms/redactor[2.1.6].

Potential causes:
- A typo in the package name
- The package is not available in a stable-enough version according to your minimum-stability setting
see for more details.
- It's a private package and you forgot to add a custom repository to find it

Read for further common problems.
Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.   

Solution I've found is - to remove roave/security-advisories, but I still don't understand how I can do this. Same problems I have with plugin install.

Composer File

{
  "name": "craftcms/craft",
  "description": "Craft CMS",
  "keywords": [
    "craft",
    "cms",
    "craftcms",
    "project"
  ],
  "license": "MIT",
  "homepage": "https://craftcms.com/",
  "type": "project",
  "support": {
    "email": "support@craftcms.com",
    "issues": "https://github.com/craftcms/cms/issues",
    "forum": "https://craftcms.stackexchange.com/",
    "source": "https://github.com/craftcms/cms",
    "docs": "https://craftcms.com/docs",
    "rss": "https://craftcms.com/changelog.rss"
  },
  "require": {
    "craftcms/cms": "3.0.18",
    "vlucas/phpdotenv": "v2.4.0",
    "craftcms/redactor": "2.1.5",    
    "dolphiq/craft3-forms": "1.1.0",
    "craftcms/contact-form": "2.2.2",
    "craftcms/guest-entries": "2.1.3",
    "nerds-and-company/schematic": "4.0.14",
    "symfony/yaml": "v3.3.6",    
    "illuminate/contracts": "v5.5.40",
    "illuminate/support": "v5.5.40",
    "nesbot/carbon": "1.32.0",
    "psr/container": "1.0.0",
    "psr/simple-cache": "1.0.1",
    "symfony/translation": "v3.3.6"
  },
  "autoload": {
    "psr-4": {
      "modules\\": "modules/"
    }
  },
  "config": {
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
      "@composer dump-autoload -o",
      "@php craft setup/welcome"
    ]
  }
}

thank for your answers

  • Is there a certain reason why you don't want to run the latest version of Craft? Because your composer json won't update it further than 3.0.18. Is that on purpose? – Robin Schambach Sep 2 '18 at 18:24
1

Try replacing your "require" section with this in your composer.json file:

"require": {
    "craftcms/cms": "^3.0.18",
    "vlucas/phpdotenv": "^v2.4.0",
    "craftcms/redactor": "^2.1.5",    
    "dolphiq/craft3-forms": "^1.1.0",
    "craftcms/contact-form": "^2.2.2",
    "craftcms/guest-entries": "^2.1.3",
    "nerds-and-company/schematic": "^4.0.14"
  },

Then, if you have Composer installed from the command line, run composer update from your project's root and let it finish.

0

Solution I've fount is - remove roave/security-advisories, but I still don't understand how I can do this.

To do that, open up your composer.json file, and remove this line:

"roave/security-advisories": "dev-master"

If that was the last line within your "require" object, make sure to delete the comma at the end of the line before it, too.

  • thx for your answer. But problem is I don't have this line in composer file, I've added this file to description – Alex Ryhluk Sep 2 '18 at 12:22
  • @AlexRyhluk can you send in a database backup and your composer.lock file over to support@craftcms.com? – Brandon Kelly Sep 2 '18 at 23:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.