1

We have hundreds of entries with the improperly spelled tag "accessibilty" (the third i is missing). A search for "accessibility" will not find them (spelled correctly).

I edited the tag on a record and it seems all the records have updated (in the control panel). That is, the tag is spelled correctly on all records.

Search however, does not find them. Both in the control panel and using craft.entries.search('accessibility') only return the ONE record that I edited. If I search for the misspelled tag ('accessibilty') I get all the remaining results.

I've emptied all caches.

1 Answer 1

2

That's because your search indexes still contain the wrong word. Please go to your utilities section in your CP and rebuild the search indexes

enter image description here

Making changes in the DB directly is sometimes not a good idea if you don't know the consequences it might have. You should have changed the title via CP rather than via DB

2
  • That's what I needed. Thank you. BTW, I did edit the tag in the control panel.
    – Mosswalker
    Commented Aug 22, 2018 at 18:02
  • 1
    Okay it sounded like you changed it on record level because you said record. That usually doesn't trigger all the required events to update search indexes. Commented Aug 22, 2018 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.