1

I've been using xampp for a long time and have never encountered a 403 error. I have many projects in my xampp/htdocs/ folder, none of them have ever had any problems until now. I have the craft files in a /craft folder inside htdocs but any time I try to visit files within this directory I am met with the 403 error.

I have been searching a solution for hours now, I edited httpd-vhosts.conf with the following but it didn't help:

<Directory "C:/xampp/xampp/craft/">
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order Deny,Allow
    Allow from all
    Require all granted
</Directory>

Again, no other folders within my htdocs directory has ever had any 403 errors. Anyone got a clue as to what is causing this and how to solve it?

2

That’s a good thing - you definitely don’t want to allow direct HTTP traffic to your craft/ folder, as people would be able to access your config settings, license key, and plenty of other sensitive data.

There’s a .htaccess file inside your craft/ folder with Deny from all in it, which is what is responsible for that 403 error you’re getting. Keep it in there!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.