1

I am getting an error notice in the Squarebit Charge plugin saying This server doesn't support TLS 1.2. but when I check with the hosting provider (Arcustech, the best!) they assure me that the server does indeed support TLS 1.2

Further, I do not see any errors when I look at a charge detail in the connected Stripe account. This has just recently popped up on a few of my projects.

Make sense to anyone?

1
2

Stripe changed up some API URLs, which threw off Charge's legacy method for detecting TLS compatibility.

The erroneous warning is fixed in Charge 2.2.3.

2
  • When can we expect a fix on this - pretty serious issue
    – Roi Agneta
    Oct 13 '18 at 16:16
  • Howdy @RoiAgneta — That erroneous warning is actually harmless, but definitely annoying. Update to Charge 2.2.3 to get rid of it. 🙂 Oct 15 '18 at 22:06
1

I'm not sure if this is helpful to anyone reading this thread, but I hacked at this a bit and made the Charge_CompatibilityService class testTLS12minimum method echo the message from the exception. It indicated a failure resolving the API host. I commented out line 26 where it sets the $spiBase variable:

//\Stripe\Stripe::$apiBase = "https://api-tls12.stripe.com";

I assume it now falls back on the API host defined in the /vendor folder. This appears to have resolved the issue, though I haven't finished the rest of my Stripe account setup so I haven't confirmed it is working end to end.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.