Every minute or so I get the "Your session has ended" popup in the admin. Entering my password just pops the message back up. If I reload the page I'm still logged in.

I'm running Craft in vagrant so maybe it's a permissions problem?

It could be related to this question since I had that exact problem but setting the permissions in vagrant fixed that particular problem.

I've tried the requireUserAgentAndIpForSession, overridePHPSessionLocation, and userSessionDuration config settings, but none of them seem to solve the popup.

  • Hey Curtis, I am having the same problem too (and I'm the one who posted the question you linked to). Any luck? Also if you don't mind sharing – what permissions settings in Vagrant solved that other problem?
    – Jason D
    Sep 27 '14 at 20:02
  • Yeah I wound up setting owner/group to root. None of Craft's config settings did anything. I'm sure there is a correct owner/group but I didn't find it. Maybe try vagrant/www-data
    – Curtis
    Oct 7 '14 at 22:40

We were experiencing this issue, as well as the randomly logging out issue.

As I answered on that question, we fixed both these issues by switching session.auto_start to Off

session.auto_start = 0

Try deleting your entire craft/storage/runtime folder. If something got out of sync with your session data, this will allow it to "start from scratch".


This was a permissions problem, I fixed it by going nuclear and setting the files owner and group to root.

config.vm.synced_folder ".", "/vagrant",
:owner => 'root',
:group => 'root',
:mount_options => ['dmode=777,fmode=666']

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.