1

I switched my craft install to be completely served over SSL. The front end continued working fine, but the backend is 404'ing all static assets. I assume this is because the http was handling the /admin/resources/ rule fine but not the https. I'm using NGINX but am using the exact same config that I was before, just adding in my SSL Certificate keys. Any thoughts on config settings to look at or lines of code to investigate?

1 Answer 1

3

So I added the following lines to my nginx file and it all worked

location ~* \.(?:jpg|jpeg|gif|png|ico|cur|gz|svg|svgz|mp4|ogg|ogv|webm|htc)$ {
    try_files $uri /index.php?$query_string;
}

location ~* \.(?:css|js)$ {
    try_files $uri /index.php?$query_string;
}
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.