1

Here's what I'm getting:

Error: An error occurred

Output: Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Installation request for craftcms/cms 3.0.18 -> satisfiable by craftcms/cms[3.0.18].
    - craftcms/cms 3.0.18 requires enshrined/svg-sanitize ~0.9.0 -> satisfiable by enshrined/svg-sanitize[0.9.0] but these conflict with your requirements or minimum-stability.
  Problem 2
    - craftcms/cms 3.0.18 requires enshrined/svg-sanitize ~0.9.0 -> satisfiable by enshrined/svg-sanitize[0.9.0] but these conflict with your requirements or minimum-stability.
    - pierrestoffe/craft-language-redirector 1.0.2 requires craftcms/cms ^3.0.0-RC1 -> satisfiable by craftcms/cms[3.0.18].
    - Installation request for pierrestoffe/craft-language-redirector 1.0.2 -> satisfiable by pierrestoffe/craft-language-redirector[1.0.2].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

I've attempted:

  • removing vendors directory
  • removing composer.lock file
  • updating via CLI
  • changing craftcms to 3.0.18 and running install

Anything else I can try?

3

I had a similar issue - update your composer.json file as per this question:

Composer was unable to install the updates

Alot of additional things may have got added to your composer.json file.

  • I had this exact same problem. I just removed enshrined/svg-sanitize from the composer.json file. This then gave an error for Twig when I tried to update, so I removed that from composer.json too. The update then worked. Not sure what the implications of doing this are, if any. – Andrew Aug 6 '18 at 14:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.