1

I'm adjusting the maxUploadFileSize in Craft, to 50MB.
In following the post below, I made several adjustments to both: php.ini and craft/config/general.php. https://stackoverflow.com/questions/3263480/upload-max-size-in-php

First, I adjusted settings in php.ini:

upload_max_filesize 
post_max_size

In general.php (craft/config), the following was already set:

  define('URI_SCHEME',  ( isset($_SERVER['HTTPS'] ) ) ? "https://" : "http://" );
  define('SITE_URL',    URI_SCHEME . $_SERVER['SERVER_NAME'] . '/');
  define('BASEPATH',       realpath(CRAFT_BASE_PATH . '/../') . '/');

 return array(

  '*' => array(
        'environmentVariables' => array(
        'omitScriptNameInUrls' => true,
        'siteUrl'  => SITE_URL,
        'basePath' => BASEPATH,
        'maxUploadFileSize' => 62914560,
        ),
  ),
  'dev' => array(
    'devMode' => true,
  )


 );

I know that that is around 62MB, but I keep receiving an error message saying that there is a 16MB limit on files. All other files great than 2MB and less than 16MB now are upload-able.
Can anyone make a suggestion as to why the standard CraftCMS default of 16MB is now in place?

Thanks for any leads

  • Basic question, but worth a double check. Is your maxUploadFileSize setting being applied to your current environment? – Simon Kuran Jul 25 '18 at 21:23
  • Go into the Utilities section in the Control Panel, click on PHP info and do a Cmd/Ctrl+F for upload_max_filesize. Does it say 50M? – Mats Mikkel Rummelhoff Jul 25 '18 at 22:17
  • 2
    Also, what web server is this? For Nginx, for example, you'll want to do client_max_body_size 0; to set it to "no limit" github.com/nystudio107/nginx-craft/blob/master/sites-available/… – andrew.welch Jul 25 '18 at 22:26
  • Thanks - this is IIS - Windows Server. Regarding applying maxUploadFileSize to my current environment, is there a command which will reveal which settings are being applied from which (if there are multiple) general.php file? – buck1112 Jul 26 '18 at 20:05
  • Is this Craft 2 or Craft 3? – Brad Bell Jul 26 '18 at 21:58
1

My guess is that your php upload_max_filesize is set to 16M, you'll need to adjust that.

| improve this answer | |
1

Since Craft 2.1 there is a setting maxUploadFileSize in craft/config/general.php. You should change this setting as well. Default value is 16777216 (16MB).

https://docs.craftcms.com/v2/config-settings.html#maxuploadfilesize

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.