1

I'm going on 5 days of banging my head on my desk here.

I'm simply not getting how to install it on my production server. I have Craft working beautifully locally...but getting it to my server is a whole other matter.

So I have ssh'd into my VPS, then run 'wget 'https://craftcms.com/latest-v3.zip'' and unzipped it to try and get it running as just a barebones install. So now I'm going through the install instructions, and am running into an error when running the './craft setup/security-key' step:

PHP Warning:  Module 'Phar' already loaded in Unknown on line 0

Craft requires PHP 7.0 or later.

I created a phpinfo file and it's returning PHP Version 7.0.30.

Any ideas why I'm getting this error?

Thanks in advance.

3

Well then. Apparently my shell user was using a different version of php than my domain. I was still at 5.6 on my shell user. I was all sorts of confused because I had a phpinfo.php file setup at my domain showing PHP 7.0, and in the web hosting domain panel, I had 7.0 chosen. Finally wrote to support and they sent directions on how to change it. Once I updated that, the security key was created just fine.

0

Try php craft setup/security-key?

  • Same response - still says I need php 7.0 or greater. Thanks for replying though! – Shad Jul 22 '18 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.