4

Using Craft 3 and recently installed the https://github.com/supercool/tablemaker plugin. When I try to update Craft via the Control panel now I am getting the following error.

Error: An error occurred

Output: Loading composer repositories with package information Updating dependencies Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for craftcms/cms 3.0.16.1 -> satisfiable by craftcms/cms[3.0.16.1].

  • craftcms/cms 3.0.16.1 requires twig/twig ^2.5.0 -> satisfiable by twig/twig[v2.5.0] but these conflict with your requirements or minimum-stability.

Problem 2

  • supercool/tablemaker 2.0.1 requires craftcms/cms ^3.0.0-RC1 -> satisfiable by craftcms/cms[3.0.16.1].
  • supercool/tablemaker 2.0.1 requires craftcms/cms ^3.0.0-RC1 -> satisfiable by craftcms/cms[3.0.16.1].
  • craftcms/cms 3.0.16.1 requires twig/twig ^2.5.0 -> satisfiable by twig/twig[v2.5.0] but these conflict with your requirements or minimum-stability.
  • Installation request for supercool/tablemaker 2.0.1 -> satisfiable by supercool/tablemaker[2.0.1].

Running update with --no-dev does not mean require-dev is ignored, it just means the packages will not be installed. If dev requirements are blocking the update you have to resolve those problems.

{
  "name": "craftcms/craft",
  "description": "Craft CMS",
  "keywords": [
    "craft",
    "cms",
    "craftcms",
    "project"
  ],
  "license": "MIT",
  "homepage": "https://craftcms.com/",
  "type": "project",
  "support": {
    "email": "support@craftcms.com",
    "issues": "https://github.com/craftcms/cms/issues",
    "forum": "https://craftcms.stackexchange.com/",
    "source": "https://github.com/craftcms/cms",
    "docs": "https://craftcms.com/docs",
    "rss": "https://craftcms.com/changelog.rss"
  },
  "require": {
    "craftcms/cms": "3.0.15",
    "vlucas/phpdotenv": "v2.4.0",
    "verbb/image-resizer": "2.0.3",
    "verbb/super-table": "2.0.7",
    "craftcms/redactor": "2.1.2",
    "ether/simplemap": "3.3.3",
    "doublesecretagency/craft-cpcss": "2.1.0",
    "doublesecretagency/craft-cpjs": "2.1.0",
    "mikestecker/craft-videoembedder": "1.0.9",
    "topshelfcraft/wordsmith": "3.0.2",
    "xpertbot/craft-wheelform": "1.9.0",
    "cebe/markdown": "1.1.2",
    "composer/ca-bundle": "1.1.1",
    "composer/composer": "1.6.3",
    "composer/semver": "1.4.2",
    "composer/spdx-licenses": "1.4.0",
    "craftcms/oauth2-craftid": "1.0.0.1",
    "craftcms/plugin-installer": "1.5.2",
    "craftcms/server-check": "1.1.1",
    "creocoder/yii2-nested-sets": "0.9.0",
    "danielstjules/stringy": "3.1.0",
    "davechild/textstatistics": "1.0.1",
    "doctrine/lexer": "v1.0.1",
    "egulias/email-validator": "2.1.4",
    "elvanto/litemoji": "1.4.0",
    "embed/embed": "v3.3.3",
    "enshrined/svg-sanitize": "0.8.2",
    "erusev/parsedown": "1.7.1",
    "erusev/parsedown-extra": "0.7.1",
    "ezyang/htmlpurifier": "v4.10.0",
    "guzzlehttp/guzzle": "6.3.3",
    "guzzlehttp/promises": "v1.3.1",
    "guzzlehttp/psr7": "1.4.2",
    "icanboogie/inflector": "v1.4.4",
    "justinrainbow/json-schema": "5.2.7",
    "league/flysystem": "1.0.45",
    "league/oauth2-client": "2.2.1",
    "lsolesen/pel": "0.9.6",
    "masterminds/html5": "2.3.0",
    "mikehaertl/php-shellcommand": "1.2.5",
    "mofodojodino/profanity-filter": "1.3.0",
    "mundschenk-at/php-typography": "v6.1.5",
    "paragonie/random_compat": "v2.0.14",
    "pixelandtonic/imagine": "v0.7.1.3",
    "psr/http-message": "1.0.1",
    "psr/log": "1.0.2",
    "seld/cli-prompt": "1.0.3",
    "seld/jsonlint": "1.7.1",
    "seld/phar-utils": "1.0.1",
    "swiftmailer/swiftmailer": "v6.0.2",
    "symfony/console": "v3.3.6",
    "symfony/debug": "v3.3.6",
    "symfony/filesystem": "v3.3.6",
    "symfony/finder": "v3.3.6",
    "symfony/polyfill-mbstring": "v1.8.0",
    "symfony/process": "v3.3.6",
    "tcb13/substringy": "1.0.0",
    "twig/twig": "v2.4.8",
    "yiisoft/yii2": "2.0.15.1",
    "yiisoft/yii2-bootstrap": "2.0.8",
    "yiisoft/yii2-composer": "2.0.6",
    "yiisoft/yii2-debug": "2.0.13",
    "yiisoft/yii2-queue": "2.0.2",
    "yiisoft/yii2-swiftmailer": "2.1.1",
    "zendframework/zend-escaper": "2.6.0",
    "zendframework/zend-feed": "2.8.0",
    "zendframework/zend-stdlib": "3.2.0",
    "ether/seo": "v3.2.8",
    "pennebaker/craft-architect": "2.2.9",
    "verbb/feed-me": "3.0.0-beta.15",
    "supercool/tablemaker": "2.0.1"
  },
  "autoload": {
    "psr-4": {
      "modules\\": "modules/"
    }
  },
  "config": {
    "optimize-autoloader": true,
    "platform": {
      "php": "7.0"
    }
  },
  "scripts": {
    "post-root-package-install": [
      "@php -r \"file_exists('.env') || copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
      "@composer dump-autoload -o",
      "@php craft setup/welcome"
    ]
  }
}
  • Most likely your composer.json file is specifying some explicit versions in its dependencies. Can you edit the question to share the contents of that file? – Brad Bell Jul 20 '18 at 20:15
  • composer.json added now. Had trouble getting it formatted right on phone. – mmc501 Jul 20 '18 at 22:49
  • 1
    @TomDeSmet Are you using PHPStorm by any chance? This happened to me once when PHPStorm suggested it could "configure the project automatically based on the contents of my composer.json file", and I clicked "Yes". Needless to say, I'm not falling for that one a second time. – Mats Mikkel Rummelhoff Jul 28 '18 at 13:54
  • 1
    Just had a similar problem to the one above. My error called for 'enshrined/svg-sanitize'. I removed that from the composer.json file, and then got another error calling for Twig. So I removed that from composer.json as well, ran the update again and it worked OK. Would be interested to know if anyone can explain further? – Andrew Aug 6 '18 at 10:42
  • 1
    I can confirm removing svg-sanitize and twig from the composer.json file did the trick. I removed them, ran composer update (which installed twig again and symphony/polyfill-ctype), then i went to the admin panel, ran the update and it worked. – cballenar Aug 6 '18 at 14:04
5

You'll need to remove every required packages besides the plugins you installed and craftcms/cms as well as vlucas/phpdotenv, clear your vendor folder and run composer update again.

For whatever reasons sometimes all required packages by Craft end up in your custom composer.json which causes these errors

I suggest you to take a look at all your plugins and cut them from your list to another one. Remove all entries except the two above and paste the plugins again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.