1

I'm having an issue with the login-page and since this is my first Craft website, I'm a little unsure of where to begin to look.

When attempting to log in to the admin interface, my username/password is rejected only with the message "An unknown error occured". The same goes for trying the "Forgot your password?" function.

As far as I can tell, the only change recently made was running the auto-update to the latest version (2.X) last week. Have not logged back in since, so this could very well be the culprit. The front end loads just fine. I do have a couple of plugins installed, but not sure how I can deactivate them without using the admin interface.

Are there some log files in the /craft folder where I can start to look?

Any help much appreciated.

1

I don't have enough rep to comment, but I can answer a few of your questions.

Craft logs are located in /craft/storage/runtime/logs.

Make sure you have a backup of the database before you uninstall the plugins. Depending on the plugin you could experience data loss. To remove the plugins you can go to the /craft/plugins directory and delete the folders.

Keep in mind if you do this it will not allow the plugin to clean up after itself.

I also found this which may help avoid the clean up issue. https://github.com/khalwat/uninstall. It is a tool that allows you to uninstall plugins via the cli.

1
  • Thanks! The logs didn't show any issues, so after some experimenting it turned out that it was the internet service (Roger´s Canada) that was causing a JS error on login. I assume it was some sort of proxy or security measure on their part that was interfering with the JS on the Craft site as well as a couple of others I visited. Back at my home office or via 4G on my phone it was no problem. – Friis Jul 7 '18 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.