2

For the last 3 days i've been trying to install Craft CMS 3 on my server.

I'm using 1&1 internet, have FTP uploaded all the files, changed the permissions for the folders and files to the right level and made sure everything is pointing in the right place.

It's worth noting i've installed Craft CMS 2 on this exact server for years with no issues at all. I also successfully installed Craft CMS 3 locally with no issues.

Going to mydomainname.com shows a craft error page with

HTTP 503 – Service Unavailable - craft\web\ServiceUnavailableHttpException

throw new ServiceUnavailableHttpException();

enter image description here

Going to /admin/install or index.php?p=admin doesn't work it just gives me an Apache Error screen with 500 Internal Server Error.

enter image description here

I've also tried using ssh and attempted to install composer but have been unsuccessful at that as my server doesn't seem to want to allow me to.

I need to get a website live asap and don't really know what I can do next! I'm not hugely experienced with servers etc.

Any advice much appreciated.

  • Are you sure the database settings are correct in .env? If they are wrong I think you will get the 503 error. – Andrew Jun 26 '18 at 14:51
  • @Andrew thanks for your response. The .env db settings are correct as far as i can tell. But also on the Craft CMS 3 install page It says to set up the db, then setup the web server and then run the setup wizard. You then get the chance to add your db details once in the wizard (docs.craftcms.com/v3/installation.html#step-4-create-a-database) – ViciousKitten Jun 26 '18 at 16:33
4

The 503 error on the home page usually indicates that Craft can't connect to the database. That's to be expected when performing a fresh installation.

The internal server error could be a typo or other misconfiguration in the /web/.htaccess file. You can troubleshoot this by renaming the .htaccess file so Apache doesn't use it, then in /config/general.php set

'omitScriptNameInUrls' => false,

index.php?p=admin should work then and you can sort out the .htaccess url rewrites later.

  • I can't thank you enough for this! It's been driving me crazy and this did work :) – ViciousKitten Jun 29 '18 at 16:37
1

In my case the /web/.htaccess file was missing a

RewriteBase /

after the RewriteEngine On statement. I had this issue only on one specific web server of a customer, so that's something you might try when the answer of Sam is temporary solving your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.