1

For the last weeks I've tried installing composer, but without any luck. I've really tried aaa looott, and how frustrating it is, it's just not working with SSLv3 for some strange reason. This was the thread I opened: Unable to get composer running to install CraftCMS

So I had to give up, at least for now, to be able to use Composer and had to decide to switch to manually setup craft, which I just did. But now I'm having a problem installing plugins. The Plugin store isn't working and it probably uses composer in the back (?). I've found a question here about how to manually install plugins without the plugin store, but... it also uses composer. Which isn't working here.

Is there another way of installing plugins manually?

  • 1
    I can't think of a clean and easy way to do this. You could try to copy/create all the dependecies you need by hand but it's going to be a mess. One solution would be to create a virtual machine or reinstall your software. You can actually download/install the files on another machine too and copy them to your PC afterwards – Robin Schambach Jun 19 '18 at 18:50
  • Thanks @RobinSchambach . So it looks like without composer realisticaly using plugins is pretty much impossible – Friksel Jun 21 '18 at 7:41
  • You could use modules instead, but yeah it's a little bit difficult. I strongly suggest you to make your composer work if you are going to continue with Craft CMS – Robin Schambach Jun 21 '18 at 8:05
  • Yes, I know it's best to use Composer and I'd really much like to, but I tried everything to make it work and after weeks and thousands of options tried (as you can read here: craftcms.stackexchange.com/questions/26517/…), adjusted and set Composer is still refuses to work. This has taken me so long (and time and money) by now I could have written my own CMS instead. So it's a real pitty, 'cause I really like to use Craft, it seems very performant and nice, but it just ain't gonna work like this. For now. – Friksel Jun 21 '18 at 8:52
  • @RobinSchambach Thanks for your responses. I finally got composer to work. The problem was ESET. see my other thread here – Friksel Jun 30 '18 at 18:56
1

Alright. Guess the conclusion to my question is that with Craft 3 it isn't realisticly possible to use the plugin store without composer.

Luckily I finally found the problem composer had in connecting to packagist via ssl. Just in case other people have problems with composer too and are running ESET, this might help: unable-to-get-composer-running-to-install-craftcms

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.