1

I'm trying to upgrade a v2 site to v3 and have done the following:

  • Verified that my server meets the v3 requirements using the Craft Server Check.
  • Followed steps 1-3 on this page.
  • Followed the directions on this page.

When I go to my control panel's URL, I get the following error: "An internal server error occurred." There's nothing in my server's "error.log" file.

As a test, I even created a fresh install of v2 on a new server instance, imported my site's data, and tried upgrading that, and I still get the server error.

FWIW, I'm running Apache 2.4, Ubuntu 16.04, PHP 7.0.30, and MySQL v5.7.22.

  • I'm guessing the "An internal server error occurred." message is a web-server styled message and not a Craft-styled one? If so, the underlying error message would be in your web server's error logs, not Craft's. – Brad Bell May 31 '18 at 17:24
  • have you tried experimenting with the db table prefix setting? you might want to set that to "craft" when running ./craft setup in the terminal to see if it works. – Clark Nelson May 31 '18 at 17:27
  • @BradBell I've checked my server's Apache error logs and there's nothing in there. – Jason Morehead Jun 1 '18 at 1:02
1

After doing some more digging in storage/logs, it turns out that the permissions were incorrect on the "cpresources" director. Once I fixed those, the upgrade progressed as normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.