1

I am moving a client site from my staging VPS to my clients preferred hosting. All of Crafts requirements check out just fine:

PHP Version 7.0.29 MySQL Version 10.2.12-MariaDB-log

However, when going to either admin or main homepage I get the following warning:

Wrong parameter count for class_alias()

The file it is pointing to is /craft/app/vendor/twig/twig/lib/Twig/LoaderInterface.php(57)

What am I possibly missing?

My VPS has the following settings: PHP Version 5.6.36 MySQL Version 5.6.39

2

So Brad tracked down the issue being Twig needs at least PHP 5.2.7 to run. As of 1.34, the minimum requirement was bumped to PHP 5.3.3. Craft bumped up Twig to 1.35 in version 2.6.3001

https://twig.symfony.com/doc/1.x/intro.html

My clients server was actually running 5.3.29. The server default was 7, bumping it up to php 5.4 fixed the site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.