2

I am using Craft on Ubuntu 12.04 servers without problems, but when trying to run it on Ubuntu 14.04 (trusty) I always get the message

Mcrypt is required.

I installed it, however, via...

apt-get install apache2 php5 mysql-server php5 php5-cli php5-common php5-curl php5-gd php5-mcrypt php5-mysql

...and restarted the web server afterwards. Any hints? Maybe this is a bug with the way craft checks for mcrypt?

8

I had to run sudo php5enmod mcrypt to enable the module.

It seems this has changed between 12.04 and 14.04—in 12.04 it was enabled automatically.

  • just a FYI, this command is required on ubuntu 14.04 ubuntu lamp prebuilt VM on digital ocean. – Luke Holder Jun 19 '14 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.