We have web site with CraftCMS Pro 2.6.2930. Due to development of new site, we set test web server (Centos/Apache/mariaDB) in our local network and migrated whole site there for testing (2.6.2993 with trial license). Site is working, but logins to craft admin webpage are rejected (log in button is greyed out).

For migration i have followed this Migration of Craft CMS from one host to another (we deleted license.key file)

Craft/storage/runtime/logs shows

2018/05/17 13:45:58 [warning] [application] tried to log in unsuccessfully.

Site content is migrated successfully.

PS: I've already tried this and it isn't working: Reset password with MySQL

Any ideas?

PS: It seems my problem is very similar to this one Control Panel access. Greyed out button since i see (almost the same) errors

  • Do you have any JavaScript errors in your browser's console on the login page?
    – Brad Bell
    Commented May 17, 2018 at 20:19
  • @BradBell yes there are 9 errors shown imgur.com/ZbwsvGp
    – user8391
    Commented May 18, 2018 at 18:40
  • btw i'm not so deep into web or craft so i could interpret it. Since similar question exists, i've uploaded all files again to the server via WinSCP using "auto" option for transfer type, but no luck there
    – user8391
    Commented May 18, 2018 at 18:48
  • What do you get when you try to load that first JS file in a browser? i.e. yoursite.com/admin/resources/lib/d3/d3.min.js
    – Brad Bell
    Commented May 18, 2018 at 21:26
  • it is d3.min.js file imgur.com/OB6TIzV Permissions are 777
    – user8391
    Commented May 19, 2018 at 5:19

1 Answer 1


Resolved! So, the console clearly showed which files were broken.

I've downloaded those files again from production server, and uploaded on my test server. Login succeed without any problems now!

I guess it has something to do with transfer mode (auto, binary, text etc) when transferring files via FTP. Transfer mode should be on auto, otherwise files might get corrupted which can cause all kind of (weird) problems. Thanks to Brad for help!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.